We are live and streaming! Come join us for a final farewell to Kritika Online, as we share stories, watch clips, and hang out with you all in Watchtower. src="https://player.twitch.tv/?channel=enmasseentertainment&autoplay=false"
height="360"
width="640"
frameborder="0"
scrolling="no"
autoplay="false"
allowfullscreen="true"
>

Problem with void monk right click

edited January 31 in General Discussion

So I'm trying to level a void monk and I want to utilize his right click skills. But no matter what I do, he seems to only do death punch immediately, through a single right click. It gives me no opportunity at all to use any other skills. I tried it with both my mouse and my controller and the result is the same. Single click = immediate death punch. He doesn't even go into the stance first. Just death punch and forget everything else. Anybody has this problem? Any solution? Thanks in advance.

EDIT: Meh, whatever. I kind of fixed it on my gamepad at least, by forcing the input to wait a little. It's a few miliseconds of input lag, but it's better than not having access to a bunch of skills. As for the mouse, still no idea. I don't have any rapid fire software on it.

Comments

  • RomanHolidayRomanHoliday Member, Player Moderators mod

    That's strange, I've never heard of that happening before. Two right clicks is a death punch so I'd assume it's forcing out two right click inputs instead of one.

  • NopiNopi Member ✭✭✭

    Yeah. As I said in my edit, I managed to fix it on my gamepad by way of workaround. But the mouse is still doing it. I don't have a gaming mouse. It's your standard low price Logitech mouse. So maybe it's just the mouse giving hints that it's going down. Or maybe it's something related with it being wireless, perhaps. I may try later with a wired mouse. When I get my hands on one.

Sign In or Register to comment.