Avatar Weapon Relics Bugged

NA server Velika

To start, before we had the server maint and roll back, I completed the 60,62,and 64 avatar weapons on my Elin Gunner, Kamkakarya. No issues at all. After we had maint and roll back, I have leveled two more characters and I will only get one relic to drop once I start the Supplies and Demands quest. My Elin Sorcerer, Haveablast, went from 58 to 65 using the 58 avatar weapon. I had 6 out of 8 pieces on my 60 weapon and that's only from the one intial drop in Velika outskirts and the rest from the Supplies and demands quest line.

On my second character, Dontfearthereaper, an Elin Reaper, I'm having the same issue. I will get the one initial drop in Velika outskirts and some from the Supplies and Demands quest line. I'm currently 6/8 pieces on my 60 weapon and my character is 62. World mobs are not dropping them, as well as instance mobs not dropping them. On both characters I have been killing mobs in the areas by mousing over the weapon and telling me where to kill stuff for the pieces.

Please look into this issue

Comments

  • Third character, an Elin archer, Maeliosa, is having the same issue. 1 relic piece drops in Velika outskirts and nothing.

    Is this issue ever going to be fixed?
  • 4th Character, Elin Brawler and still no avatar weapon at 60....

    I take it this never going to get fixed.....
  • MalxMalx
    edited June 2019
    I'm dealing with the exact same situation. I'm also on NA Velika server. Got my lvl 58 Avatar weapon. I'm lvl 62 now and only 6/8 shards have dropped for the lvl 60 weapon. I've tried various locations, killing lvl 60+ mobs and BAMs to no avail.

    I guess this is a bug that still isn't fixed.
  • Same happens for me, and I play solely on the Kaiator server ...
    EME needs to fix this.
  • Still broken. Leveled a Slayer, Mystic, and 2 popo brawlers. None of them got passed a 58 weapon.
  • mine 2 i have a reaper elin and i have 5/8 and i cant get the other oe i tried every dungeon that drops its and every location and every enemy in those locations for hours and i cant seem to get anything now
Sign In or Register to comment.