[TERA PC & Console] En Masse is closing, but TERA lives on! We will continue to support TERA PC (NA) and TERA Console until services are transferred. Our Service Moving Info page is now live here: https://bit.ly/tera_service_moving

Constantly freezing and crashing, trying to fix for months



  • 5WG9CLR9R45WG9CLR9R4 ✭✭
    edited October 2019

    So under my radeon overlay in game monitoring, it showed my system ram utilized at 20gb, it didn't move up or down, just stayed there. The gpu usage and temps etc was all good up until the freezing, then gpu usage would drop to zero until I ctrl-alt-del and cancelled out again, bringing me back into the game.

    I wonder if this whole ordeal is an issue with Tera simply seeing too much ram memory and hitting caps really quick in those populated areas.
    Is there an easier way for me to limit the amount of system ram that Tera sees? I mean besides pulling it out physically (as I want that ram for every other application of course).

    I did try a third party program before, forgot the name. But it didn't help. Process lasso was another program I tried, but that was more for utilizing specific cores (when I thought the issue was cpu related).

    I now believe that this is strictly memory related, not because of my memory modules, but because I have so much of it, and because Tera can't tell wtf is going on due to it's poor optimization.

    It is my hope that I get this figured out, so that others experiencing similar issues could turn to this thread and save themselves all the headaches that I have been going through.

    FYI, I just tried a VPN just to determine if it was connection related. Nope, network holds stable with a good ping in both ch1 Highwatch (crowded) and ch2 Highwatch (low population).

    I can simply just avoid the areas and continue gaming with that odd crash here and there sure, but something is nagging at me to pin point this issue and possibly resolve it to a point where I can actually join the rest of you in crowded areas while simply suffering the terrible fps at the worst (no crashes).

  • One last bump, just in case we have some lvl99 computer techs on these forums.

  • MargaretRoseMargaretRose ✭✭✭✭✭

    Did you try setting/increasing your virtual memory?
    Seemed to help in my case.
    Albeit most likely placebo.

  • 5WG9CLR9R45WG9CLR9R4 ✭✭
    edited October 2019

    Yeah I increased my page file to 9.5gb, no changes :/

    Clean installed graphics driver after DDU under safe mode, no changes :/

  • MargaretRoseMargaretRose ✭✭✭✭✭

    I see.
    Did you disable windows game mode?

  • 5WG9CLR9R45WG9CLR9R4 ✭✭
    edited October 2019

    I did.

    Sorry, even though I tried to make my trouble shooting attempts all noted in my post, I obviously forgot to document some of it.
    But yes, tried that and no luck either

    With that said, I don't think I have tried leaving game mode on?...Maybe that is what this old 32bit application needs? Hmmm

    Ill post back, prob with undesirable results still :/

    Edit: Game mode on made no difference.

  • 5WG9CLR9R45WG9CLR9R4 ✭✭
    edited October 2019

    I doubt this is a "memory leak", my fps doesn't slowly drop.
    In those busy cities, my game will just have a heart attack and freeze (literally every time under medium population).
    Raids are once in a while.

    Questing/dungeons etc are typically never an issue.

    It is my assumption that this has to be something to do with the extra memory required to render all the textures of things popping in and out such as live players.

    So while it's a doubtful "memory leak", something is causing my system (within this game only) to freak out and say "awe heck naw!", even with 64gb of ram memory (yes I know that a 32bit client will only use up to 2.5-3gb or so).

    The memory usage in the problem areas seems to hover around 2.5gb up to just around 2.8gb before the issues start to happen, but fps stays consistent.

    I can go into Highwatch under channel 1 with medium population and replicate my problem just by running around for a couple minutes...every time.

  • 5WG9CLR9R45WG9CLR9R4 ✭✭
    edited October 2019

    So I just observed that high memory usage isn't always the sign a freeze is coming. I have had game freezes/ lock ups consistently in Velika channel 1 low population with about 2.1gb memory usage just now. It seems it is any area that fps naturally starts to tank the most. Again the cities and sometimes raids

    I should add that in Highwatch or Velika for example, my fps seems to be around 30-40fps when the freeze/lock up occurs, but it's steady at that range in the areas anyway, so it's not like I notice the frames start to stutter more etc before the freeze/lock up. There is no indicator that it is coming essentially, I just know it is coming never the less.

    Currently I play at high settings without AA, as I have already tired to lower it all to minimal with no real difference other than the freeze/lock up possibly taking slightly longer to surface, but still inevitable never the less.

    CPU usage and temp seems fine, the only time I see it spike to maybe 75 degrees (which is not high anyway), is when the freeze/ lock up happens and I check task manager before cancelling out and returning to the game in an effort to unfreeze.

    I tried to manually end tasks of various background processes in task manager as I froze and continued testing/gameplay.
    No luck.

    In bullet form, the current facts.

    -Only happens with this game
    -This game is probably my only 32bit dx9 game (edit: nope, I play CS:GO without issues...so it's simply a Tera problem)
    -No noticeable "memory leak"
    -Seems to isolate crashes/freezes in cities like Highwatch and Velika and sometimes occasional raids (haven't ventured to new island yet).
    -Dungeons and questing is almost always no problem
    -Already attempted to disconnect all usb hardware (other than keyboard/mouse...but again most likely not a "memory leak")
    -Already attempted the usual software fixes such as adding exceptions for anti virus, fresh install of gpu driver, compatibility modes, etc
    -All system drivers are up to date including system bios

    So...is it simply my fate here?

    I am outta ideas :anguished:

  • edited October 2019

    @5WG9CLR9R4 said:
    So...is it simply my fate here?

    I am outta ideas :anguished:

    Honestly, at this point, the only thing you can try is a clean boot and/or a clean install of the OS (maybe on a different driver/partition if you want). Otherwise, yeah, unfortunately it's your fate. Send your diagnostics to EME in a support ticket so they have a record of the broken configuration in case they get others like it and can find the commonality.

  • Yeah, I think I will just give up.
    It's so very doubtful that an os reinstall will make a diff if literally everything else works no problem, including other 32bit dx9 games. Something within Teras coding/engine and my hardware/software is not agreeing with each other. I will just hope that a future patch fixes it by some miracle.

    Off to WoW I guess.

    I'll be checking these forums routinely for the time being.

    Take care all, and thanks for your efforts.

  • Speaking of diagnostics, I have ran that before. Said something network related. I looked it up, and apparently a "common" diagnostic result that most just ignore? Maybe I'll run it again and post here.

  • 5WG9CLR9R45WG9CLR9R4 ✭✭
    edited October 2019



    OS: Windows 10 Home 64-bit (10.0, Build 18362)
    CPU: 12 Processor running at 3.7G
    RAM: 63.82GB
    Free drive space: 99.2GB
    DirectX: DirectX 12


    === OVERVIEW

    Your system meets the recommended system requirements.



    Our tests indicate that you might be experiencing internet connectivity issues. Below are some steps you can take to resolve common internet connectivity issues.
    1. Restart your computer.
    2. Make sure the network cable is correctly plugged into your computer and router.
    3. Reset your router by unplugging the power cable, waiting several seconds, and then plugging it back in. Once completed, restart your computer.
    4. Contact your internet service provider for assistance if you think the problem may be related to a service outage.


    We were unable to connect to our servers in a timely manner from this computer. Please check your internet connection is active and functioning.

    OS: OK
    CPU: OK
    RAM: OK
    HD: OK



    google name lookup - 0.023 seconds
    google port 80 connect - 0.030 seconds
    google port 443 connect - 0.001 seconds
    TERA port 80 connect - 0.113 seconds
    TERA port 443 connect - 0.078 seconds
    TERA port 10001 connect - 0.075 seconds
    Closers WORLD port 1231 connect - 0.149 seconds
    Launcher Asset CDN port 443 connect - -1.000 seconds
    Patch CDN port 443 connect - -1.000 seconds
    Prerequisite CDN port 443 connect - 0.061 seconds
    Closers Catalog CDN port 443 connect - 0.067 seconds
    ST3 Catalog CDN port 443 connect - 0.052 seconds
    Tera Catalog CDN port 443 connect - 0.062 seconds



    Windows IP Configuration

    Host Name . . . . . . . . . . . . : DESKTOP-LQS5NGD
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Hybrid
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No
    DNS Suffix Search List. . . . . . :

    Ethernet adapter Ethernet:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Killer E2500 Gigabit Ethernet Controller
    Physical Address. . . . . . . . . :
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes

    Wireless LAN adapter Local Area Connection* 2:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Microsoft Wi-Fi Direct Virtual Adapter
    Physical Address. . . . . . . . . :
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes

    Wireless LAN adapter Local Area Connection* 3:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Microsoft Wi-Fi Direct Virtual Adapter #2
    Physical Address. . . . . . . . . :
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes

    Wireless LAN adapter Wi-Fi 2:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Killer(R) Wireless-AC 1550 Wireless Network Adapter (9260NGW) 160MHz

    NetBIOS over Tcpip. . . . . . . . : Enabled

    ~I removed the addresses and such, but this is the first bit of info in a nut shell. Possibly the game hates my network card? Works great with everything else mind you.
    Is there an ini config for changing network related stuff I wonder?

  • 5WG9CLR9R45WG9CLR9R4 ✭✭
    edited October 2019

    ...and then I found this thread.


    The post at the bottom sums up all the attempts to verify whether the game had issues with my connection or not.

    Opened ports, flushed dns, turned off firewall etc etc already.

    I notice no ping spikes before the freezes/lock ups, although it is hard to know for sure as I am busy running around to test stability before my freeze/lock up.

    But yes, the network...or the way the game handles my network connection could also be a logical explanation as to why this issue happens in "busy areas" of the game. Possibly was never a graphical or memory issue at all?

  • I have submitted a ticket with my attached diagnostic results. Hopefully they have some sort of idea...

    I also pointed them to this thread for more detailed information.

  • Okay, I don't want to give my hopes up here; But I have been online for a solid hour messing around in both Velika and Highwatch (channel 1 is populated but not "medium" still "low") and I haven't froze or crashed yet.
    I would have experienced the issue in channel 1 even if low population with enough effort before.

    All I did was update my Killer networking card driver and application. A new one just came out this month and I wasn't aware.

    I will test it more tomorrow when the population is higher.

    But this looks good so far folks! Wish me luck.

This discussion has been closed.