[TERA PC & Console] En Masse is closing, but TERA lives on! We will continue to support TERA PC (NA) and TERA Console until services are transferred. Our Service Moving Info page is now live here: https://bit.ly/tera_service_moving

play button greyed out

I tried everything, no idea what else to do.

Comments

  • i have the exact same problem. i also tried everything including netsh and ipconfig resets as well as resetting the computer.

  • edited September 25

    Unfortunately, if you are a new player, this is not a bug. Until the publisher transition occurs, new players aren't allowed to join the game, so you will notice the Play button greyed out in the Launcher. (If you have an existing account where you've played TERA PC before, it will work.) Hopefully the timeline for the transition will be posted soon.

  • Have you found a solution for that ?

  • As noted above, it's because of the impending publisher transition, but you'll be able to play after the game transitions to Gameforge on November 12th.

Sign In or Register to comment.