Extreme lag & unable to use instance matching. [mt server is down]

edited May 9 in General Discussion
MT server is experience extreme lag (1000+ ms ping) and the instance matching is not working.
Please fix

Comments

  • Update. Server just went down.
  • The operations team is on it. We'll get it up and running ASAP. Sorry about that!
  • Halrath wrote: »
    The operations team is on it. We'll get it up and running ASAP. Sorry about that!

    not to sound like a [filtered]... but can it come back without the lag? i kinda like to play the game without it freezing and almost making parties wipe :/
  • Don't worry... the problem is with your routes. Please call your ISP.
  • Halrath wrote: »
    The operations team is on it. We'll get it up and running ASAP. Sorry about that!

    Can you go back to calling it the Ops team? I liked that better....
  • Halrath wrote: »
    The operations team is on it. We'll get it up and running ASAP. Sorry about that!

    Of course, it will be fixed Soon™
  • They are closing threads now xD well organized community moderators.
  • edited May 9
    cemi33 wrote: »
    They are closing threads now xD well organized community moderators.

    yep they removed mine (which was one of the first ones up) lol

    edit: they combined it with another thread making it seem i never made it at all lol but w.e xD
  • edited May 9
    The problem is not just MT; they have it the worst but my party has wiped twice on DFHM because the lag spikes are that bad. (FF)

    This is what happens when server issues persist for months, unsolved, and drop new content expecting everything to be ok.
  • https://gyazo.com/40335881df629cf9b5f86ecabd5216cd

    "Servers are better than ever" -EME 2017
Sign In or Register to comment.