[TERA Console] We will enter maintenance on 05/26 (Tue) at 7:00 p.m. PT, and have an expected downtime of 3 hours. For details, please visit the following thread: http://bit.ly/teraconsolemaintenance
[TERA PC] We confirmed that an issue with Civil Unrest persists, so Civil Unrest will remain disabled until further notice. Thank you for understanding.

Can't enter server

I logged out of a character on TR, was going to log in to FF. Got to server select screen, but picking a server and then pressing "enter server" just refreshes the server list. Tried running repair function, disabling all security software, running as admin, and nothing made a difference. If anyone has experienced this problem before, would appreciate a solution.
Thank you for your time


  • To be clear, you clicked on FF and it went to the whole vortex screen then went back to the server list?
  • SolheimSolheim ✭✭✭
    No, it just refreshed the server list. No animation. I tried double clicking on server, and clicking server then enter server button.
    It just does the same animation that pressing the refresh server list does
  • Does this happen with all the servers you try or jus FF?
  • SolheimSolheim ✭✭✭
    All. Same issue with TR, tried CH just to be sure. Currently letting it patch after a fresh install, will see if that helps at all.
  • SolheimSolheim ✭✭✭
    Fresh install worked.
    Ty to noble for your time.
    GM can close this thread if they want
Sign In or Register to comment.