[PS4/XB1] We will be entering into maintenance downtime on 10/21 at 7pm PDT, and have an expected downtime of 3 hours. For details, please visit the following link: http://bit.ly/teraconsolemaintenance

Story quest Fraya's Fury "Dangons Treasure quest 3/9

I am inside the Dagons Chantry, activated the Relic of Dagon but wouldn't let me pick up the Cerulean Gem. Am i doing some thing wrong..

Comments

  • It's not you. I occasionally had issues picking up that gem on the PC version (one time, i had to keep hitting "F" over 20 times and it kept targetting the wrong object). Might be the same interaction issue on console where you may need to try repositioning your character.

    My brawler is a few levels away from hitting that part of the quest so I am going to give it a try when I get there.
  • Its telling me cannot pick up gem
  • It seems as if it getting stuck in the statue
  • Yeah, this is a big issue. I'm stuck there too, and I've seen a few other threads on this problem. I've tried hitting up Tera on Twitter, but still no reply. Can't even delete the quest to test again, because it's a story quest. I've just given up on it, and moved on to the other story quests. Sad thing, that is literally the last part of that story quest.
Sign In or Register to comment.