[PC] We are aware of issues surrounding the event EP booster, and are working to resolve this. Currently, we are working towards having this fixed on Tuesday, 02/25 in a hotfix maintenance. We will have further details as we approach this fix. Thank you for your patience and understanding!

Entering server after July 19 maintenance

Is anyone else having any issues with this? I just sent in a bug ticket, but I was wondering if anyone had a similar issue and if there's a glaringly easy solution to why I cannot enter a server even though all the servers are up.
«13

Comments

  • Elinu1Elinu1 Canada ✭✭✭✭
    Same here.
  • Same here...
  • Yup.... same here
  • Yup.... same here
  • Same here...
  • I actually just posted a thread about the same issue.
  • Kira98Kira98 ✭✭✭
    #EME mant....
  • Same here. Sent in a ticket, reloaded launcher, repaired launcher and restarted pc, nothing is working. Last resort I'm reinstalling game and hoping that works. Man I hate maint. days they always screw something up.
  • No point in reinstalling. I doubt the issue is on your end.

  • 66P6YL9MH3 wrote: »
    I actually just posted a thread about the same issue.

    Why didn't you look before you posted?
  • 66P6YL9MH366P6YL9MH3 ✭✭
    edited July 2018
    Lustre wrote: »
    66P6YL9MH3 wrote: »
    I actually just posted a thread about the same issue.

    Why didn't you look before you posted?

    I posted before you did. When I noticed your thread, I tried to delete mine, but I can't.
  • 66P6YL9MH3 wrote: »
    Lustre wrote: »
    66P6YL9MH3 wrote: »
    I actually just posted a thread about the same issue.

    Why didn't you look before you posted?

    I posted before you did. When I noticed your thread, I tried to delete mine, but I can't.

    You must be blind or not very good with numbers if you think 1:54 pm is before 1:50 pm...
  • omega luul
  • Other members of my guild are on and playing so I dont get how it is only a problem for some and not all.
  • Lustre wrote: »
    66P6YL9MH3 wrote: »
    Lustre wrote: »
    66P6YL9MH3 wrote: »
    I actually just posted a thread about the same issue.

    Why didn't you look before you posted?

    I posted before you did. When I noticed your thread, I tried to delete mine, but I can't.

    You must be blind or not very good with numbers if you think 1:54 pm is before 1:50 pm...

    When I went onto the forums, your post was not there, therefore I created my own.
This discussion has been closed.