[TERA PC] Known issue: Little Red Tokens from the Little Red and the Wolf event have an inventory limit of 999 and if receiving a Vanguard Request reward will raise your token quantity over the limit, you will not be able to receive any of the reward items. We apologize for the inconvenience, but ask that you please exchange tokens prior to completing dungeon Vanguard Requests if you are approaching the inventory limit. Event details: https://tera.enmasse.com/news/posts/tera-anniversary-little-red-and-the-wolf
[TERA PC] We confirmed that an issue with Civil Unrest persists, so Civil Unrest will remain disabled until further notice. Thank you for understanding.

Quest: Sikander's Bane Bug in PS4

edited November 2018 in Console - Bug Reports
I can not complete the quest, it says to report to Karia and above the head the asterisk (*) does not appear, I select it and it does not appear to complete the quest. Any solution?



  • I already tried to remove the mission and select it again, give it in unstuck in system, closing the game and enter again and continued the same. I am blocked!
  • Already solved. Sorry for the inconvenience.
  • wow what a great fix
  • How did you solved the problem?
  • How did you fix this?
  • In the OP's post, he said that he was supposed to speak to "Karia", and in the screenshot he provided, it shows him speaking with "Karia", but the information she was giving him was of no value, nor did it further the quest. However, if you look at the other screenshot he provided, the quest instructions show that he was supposed to speak to the goddess "KAIA". My "guess" (I may be wrong, because the OP has not responded to people's questions in here) is that he figured out he needed to speak with Kaia, and the quest advanced when he did. If anyone else is having this problem, then I recommend that you check to be sure you are speaking with Kaia, not Karia.
Sign In or Register to comment.