[PC] We are aware of issues surrounding the event EP booster, and are working to resolve this. Currently, we are working towards having this fixed on Tuesday, 02/25 in a hotfix maintenance. We will have further details as we approach this fix. Thank you for your patience and understanding!

Can't launch tera with new launcher.

https://imgur.com/zIA203c

Can't launch tera with new launcher.
Game installation directory is correct.
No files have been edited.
No third party programs running.

Launcher will say "Playing", then it goes back to "Play" without launching the game.

Comments

  • edited October 2019

    Don't know but if the repair doesn't work, then I would run the launcher in debug mode and send in a support ticket with the log files.

  • Thanks for reply, tried that, didnt work.
    Thing is, the new launcher 'used' to work like 2-3 months ago, when i first tried it.

    In any case, i decide to just reinstall the entire game.

  • @Fanfreya said:

    Thanks for reply, tried that, didnt work.

    Okay glad you got it working by reinstalling anyway, but yeah -- the point of running debug mode isn't to fix it, but just to gather the log file that support would need to diagnose the error.

Sign In or Register to comment.