New Weird Tera Error? Insert disk into Drive?

So I was about to go play some tera when I constantly get an error telling me to Insert my disk into the drive. What gives? Anyone else having this problem?


  • I did, but it only did it once. I would assume something is going horribly wrong with TERA right now for it to think it still needs disks to play.
  • Elinu1Elinu1 Canada ✭✭✭✭
    I get that stupid error every time I launch the game, quite annoying having to click continue like 2 dozen times.
  • StarSpriteStarSprite ✭✭✭✭ might be your best bet for getting it resolved.
  • Try closing out of the launcher and trying again, and also try doing a repair from the, "Tools." Button.
  • @kubitoid
    I actually have and nothing happened. It played the game without running the disk.
  • same issue, i click the x to cancel 9 times and it carries on. don`t know why it takes 9, but always does.
  • MidokuPastaMidokuPasta ✭✭✭✭
    kubitoid wrote: »
    or you can do as it asks. insert disk with game distributive into drive

    Yeah only I didn't buy the game I simply downloaded it lol so that is just ignorant most people here don't have a hard disc of the game
  • i'm really loving all these problems people are having, only because i have none. the only issue i've had since i've started playing in mid 2014 is the launcher not saving my info. i must be doing something right to not have any problems. obviously it's not EM or BHS problems, it's on the users end of things. which is sad people haven't realized this, and fixed their own stuff. i'll just continue to play with no lag or dcs. really loving the game because of the lack of issues i'm having
  • I have never seen the insert disk error with TERA. The installer TERA initially shipped with would have been able to throw that error since it was distributed on a set of disks, but that was long before we moved to free-to-play. I've asked our QA team if they have seen that error, but they have not been able to recreate it.

    Is is possible you have a mod installed? Have you tried running a error check scan on your hard drive? Are you trying to run TERA from an external drive?
  • I think it may be a good idea to check the Windows Event Viewer when this error occurs. While doing so, look for Tera in the application logs where it shows the warnings/errors. It may actually give a starting point of the type of error or where to look if it is something locally on the machine that is causing this issue. Plus another idea to see is does this only occur with users using windows 10 as their operating system or different operating system.
  • Geletron wrote: »
    Is is possible you have a mod installed? Have you tried running a error check scan on your hard drive? Are you trying to run TERA from an external drive?

    I have 2 pc`s both identical except for gpu. AMD 460 2gb on one and nvidia 660 2gb on the other. Tera is installed on a corsair force LE ssd, the error keeps happening on the amd 460 one. Both are win 10 pro, and i ran the tera repair tool which found no errors. As long as i cancel the insert disc error 9 times, it plays as normal...but hangs until i do so. My ping in game has been normal (between 30-60ms) in game.
    since i was having the error i have fresh installed win 10, on a full formatted drive and re-installed tera. no other programs on computer yet besides applicable drivers. Also the drive is internal, regular sata drive. nothing fancy (ie..usb/esata/ ect..)
  • NobunautNobunaut ✭✭
    edited November 2016
    Geleton has a good point, I run TERA from my D external drive and that could possibly be a problem with you. I only made it work by making sure the launcher was also on the C drive to stop it from happening.
Sign In or Register to comment.