[PS4/XB1] We will be entering into maintenance on 1/27 at 6pm PST, and have an expected downtime of 3 hours. For details, please visit the following link: http://bit.ly/teraconsolemaintenance

Tera Launcher patching

I'm trying to patch the game (I haven't played since the archer update) but the launcher keeps doing this. http://imgur.com/a/APwjP I have tried closing/opening the launcher which then goes through the patch process again every time, I also tried to re-download/install the game again but this keeps happening. Does anyone know how to fix it?
Thanks for any help. :)

Comments

  • For the most part, we see this when there is conflicting software that restricts the needed connection to the Launcher / Game Client.
    You might need to temporarily remove some Security Software you have installed on the PC, or perhaps lower some Security Settings on Windows Firewall / Windows Defender, then restart the computer and check to see if the Launcher functions as intended.

    If still no luck, please feel free to submit a Support Ticket and our Agents will be happy to assist. :)
  • Thank you for the help! I'll try that now. :D
Sign In or Register to comment.